If you'd like to see existing mods come to the Bedrock platform, please contact the talented community creators of these mods and ask them to take a look at the modding API documentation at http://aka.ms/minecraftaddons Bugs, requests for specific existing mods, feature lists, and support issues will be removed. Please put mashup requests and copyrighted content requests in Marketplace.

0

Kubo addon armor not working

7 Comments

Please sign in to leave a comment.

Sorted by oldest
  • 5
    Registered User commented
    Comment actions Permalink

    The armor was working fine and then just one time I took it off and it was permanently stuck to my body.... And now I can't put on any of the other armors

  • 0
    Registered User commented
    Comment actions Permalink

    Hi, I was having this issue too but it looks like you have to combine all the armor of the same set into a single set through a crafting table. It should turn into a bag looking thing. Then you should be able to equip it. Hope this helps!

  • 0
    Registered User commented
    Comment actions Permalink

    I'm having the EXACT same problem. I bought this expansion for my son because of all the armor and it WILL NOT let me equip any individual armor or armor sets.
    Such a waste of money!

    Edit: Make sure you have no armor equipped. Equip an armor set in your hand and then press and hold the action button to equip.

  • 1
    Registered User commented
    Comment actions Permalink

    This happened to me after death. It shows I have the obsidian armor on graphicly but I only have half the armor I should and I can not put on or change any armor anymore

     

    I /cleared and that fixed the ui problem but the armor sets are completely useless now 

    Please help

  • 1
    Registered User commented
    Comment actions Permalink

    I was wondering, if any of you guys know how to fix a glitch in the survival expansion pack where it shows that I have an armor set on but I don’t and I can’t put another one on or take it off, if you do know how to fix this please let me know

  • 0
    Registered User commented
    Comment actions Permalink

    Put armor on took off still shows it on there

  • 0
    Registered User commented
    Comment actions Permalink

    The armor in the mod, when I died with it on, it, stayed on, and even when/clear was enabled the armor was gone, but the effects are still there. I am now no longer able to use the modded armor. Please fix this glitch