Welcome to the launcher category! Please do not post bugs and support issues here, they will be removed.

5

I hate the fact that the earliest version you can now play is 1.0

1 Comments

Please sign in to leave a comment.

Sorted by oldest
  • 1
    Registered User commented
    Comment actions Permalink

    Buddy go to settings and turn on Historical versions